본문으로 바로가기
728x90
반응형

CleanCode - 로버트 C.마틴

▷ 1. 깨끗한 코드

코드란? 

  • 기계가 실행할 정도로 상세하게 요구사항을 명시하는 작업이 프로그래밍이며 이렇게 명시한 결과가 코드이다.

깨끗한 코드란?

 

1. 비야네 스트롭스트룹

우아하고 효율적인 코드, 논리가 간단해야 버그가 숨어들지 못하며 의존성을 최대한 줄여야 유지보수가 쉬워진다. 
오류는 명백한 전략에 의거해 철저히 처리한다. 성능을 최적으로 유지해야 사람들이 원칙없는 최적화로 코드를 망치려는 유혹에 빠지지 않는다.
깨끗한 코드는 한 가지를 제대로 해야한다.

 

2. 그래디 부치

단순하고 직접적이다. 잘 쓴 문장처럼 잘 읽힌다.(가독성 강조)
설계자의 의도를 숨기지 않으며 명쾌한 추상화와 단순한 제어문으로 가득하다.

 

3. 큰 데이브 토마스

작성자가 아닌 사람도 읽기 쉽고 고치기 쉽다.
단위 테스트 케이스와 인수 테스트 케이스가 존재한다. 깨끗한 코드에는 의미 있는 이름이 붙는다.
특정 목적을 달성하는 방법은 하나만 제공한다. 의존성은 최소이며 각 의존성을 명확히 정의한다.
API는 명확하며 최소로 줄인다. 언어에 따라 필요한 모든 정보를 코드만으로 명확히 표기할 수 없기 때문에 문학적으로 표현해야 마땅하다.

 

4. 마이클 페더스

언제나 누군가 주의 깊게 짰다는 느낌을 준다.
고치려고 살펴봐도 딱히 손 댈 곳이 없다. 작성자가 이미 모든 사항을 고려했으므로.
고칠 궁리를 하다보면 언제나 제자리로 돌아온다. 그리고는 누군가가 남겨준 코드, 누군가 주의 깊게 짜놓은 작품에 감사를 느낀다.

        

5. 론 제프리스

모든 테스트를 통과해야 하며 중복이 없다.
시스템 내 모든 설계 아이디어를 표현하며 클래스, 메서드, 함수 등을 최대한 줄인다.

 

6. 워드 커닝햄

코드를 읽으면서 짐작했던 기능을 각 루틴이 그대로 수행한다면 깨끗한 코드라 할 수 있다.
코드가 그 문제를 풀기 위한 언어처럼 보인다면 아름다운 코드라 불러도 되겠다.

 

우리는 저자다

  • javadoc에서 @author필드는 저자를 소개한다. 우리는 저자다. 저자에게는 독자가 있다. 그리고 저자에게는 독자와 잘 소통할 책임도 있다.
  • 코드를 짤 때는 자신이 저자라는 사실을, 여러분의 노력을 보고 판단을 내릴 독자가 있다는 사실을 기억해야 한다.

▷ 2. 의미있는 이름

의미를 분명히 밝혀라

  • 변수나 함수 그리고 클래스 이름은 다음과 같은 굵직한 질문에 모두 답해야 한다. 변수, 함수, 클래스의 존재 이유는? 수행 기능은?
  • 따로 주석이 필요하다면 의도를 분명히 드러내지 못했다는 말이다.
public List<int[]> getThem() {
    List<int[]> list1 = new ArrayList<int[]>();
    for (int[] x : theList) {
        if (x[0] == 4) {
            list1.add(x);
        }
    }
}
  • 위 코드는 의도를 짐작하기 어렵다. 문제는 코드의 단순성이 아니라 함축성이다. 즉 코드 맥락이 코드 자체에 명시적으로 드러나지 않는다.
  • 목적은 지뢰찾기 게임을 만드는 것이었다고 한다면 아래 코드와 같이 수정할 수 있다.
public List<int[]> getFlaggedCells() {
    List<int[]> flaggedCells = new ArrayList<int[]>();
    for (int[] cell : gameBoard) {
        if (cell[STATUS_VALUE] == FLAGGED) {
            flaggedCells.add(cell);
        }
    }
    return flaggedCells;
}
  • 코드의 단순성, 연산자와 상수의 수, 들여쓰기 단계 또한 동일하나 코드는 더욱 명확해졌다.
  • 더 나아가 int배열을 사용하는 대신 칸을 간단한 클래스로 만들 수 있다. 또한 좀 더 명시적인 함수를 사용해 FLAGGED라는 상수를 감춰도 되겠다.
public List<int[]> getFlaggedCells() {
    List<Cell> flaggedCells = new ArrayList<Cell>();
    for (Cell cell : gameBoard) {
        if (cell.isFlagged()) {
            flaggedCells.add(cell);
        }
    }
    return flaggedCells;
}
  • 단순히 이름만 고쳤는데도 함수가 하는 일을 이해하기 쉬워졌다. 바로 이것이 좋은 이름을 주는 위력이다.

그릇된 정보를 피하라

  • 널리 쓰이는 의미가 있는 단어를 다른 의미로 사용하면 안된다.
  • 서로 흡사한 이름을 사용하지 않도록 주의한다.
  • 여러 계정을 그룹으로 묶을 때 실제 List가 아니라면 accountList로 명명하지 않는다. accountGroup, bunchOfAccounts, Accounts 등으로 칭할 수 있다.

인코딩을 피해라

  • IDE는 코드를 컴파일하지 않고도 타입 오류를 감지할 정도로 발전했다. 따라서 이제는 헝가리식 표기법이나 기타 인코딩 방식이 방해가 될 뿐이다.
  • 멤버 변수에 m_이라는 접두어를 붙일 필요도 없다.
  • 때로는 인코딩이 필요한 경우도 있다. 다만 인터페이스 이름은 접두어를 붙이지 않는 편이 좋다고 생각한다. 인터페이스가 shapeFactory일 경우 구현체인 클래스는 shapeFactoryImpl 또는 CShapeFactory이라 명명한다.

클래스 이름

  • 클래스명, 객체명 명사, 명사구가 적합하다.
  • Customer, WikiPage, Account, AddressParser 등이 좋은 예이며 Manager, Processor, Data, Info 등과 같은 단어는 피하고 동사는 사용하지 않는다.

메서드 이름

  • 메서드명은 동사나 동사구가 적합하다.(postPayment, deletePage, save 등이 좋은 예이다.)
  • 접근자, 변경자, 조건자는 javabean 표준에 따라 값 앞에 get, set, is를 붙인다.
String name = employee.getName();
customer.setName('mike');
if (paycheck.isPosted) {}
  • Customer, WikiPage, Account, AddressParser 등이 좋은 예이며 Manager, Processor, Data, Info 등과 같은 단어는 피하고 동사는 사용하지 않는다.

한 개념에 한 단어만 사용하라

  • 추상적인 개념 하나에 단어 하나를 선택해 이를 고수한다.
  • 똑같은 메서드를 클래스별로 fetch, retrieve, get으로 제각각 부르면 혼란스럽다.

말장난을 하지마라

  • '한 개념에 한 단어만 사용하라' 규칙을 따르기 위해 같은 맥락이 아닌데도 일관성을 고려해 메서드명은 둘 다 add라고 칭하면 안된다.
  • 새 메서드는 add가 아닌 insert 또는 append라는 이름이 적당하다.
  • 집중적인 탐구가 필요한 코드가 아니라 대충 훑어봐도 이해할 코드 작성이 목표다.

해법 영역에서 가져온 이름을 사용하라

  • 코드를 읽은 이도 프로그래머이기 때문에 전산 용어, 알고리즘 이름, 패턴 이름, 수학 용어 등을 사용 해도 괜찮다.
  • 모든 이름을 문제 영역에서 가져오는 정책은 현명하지 못하다.
  • VISITOR 패턴에 친숙한 프로그래머는 AccountVisitor라는 이름을 금방 이해한다.

문제 영역에서 가져온 이름을 사용하라

  • 적절한 프로그래머 용어가 없다면 문제 영역에서 이름을 가져온다.
  • 코드를 보수하는 프로그래머는 그 분야 전문가에게 의미를 물어 파악할 수 있다.
  • 문제 영역과 관련이 깊은 코드라면 문제 영역에서 이름을 가져와야 한다.

한 개념에 한 단어만 사용하라

  • 추상적인 개념 하나에 단어 하나를 선택해 이를 고수한다.
  • 똑같은 메서드를 클래스별로 fetch, retrieve, get으로 제각각 부르면 혼란스럽다.

의미있는 맥락을 추가하라.

  • firstName, lastName, city, state 등의 변수가 있을 경우 주소라는 사실을 금방 알아챈다. 하지만 메서드에서 state라는 변수 하나만 사용한다면?
  • addr이라는 접두어를 추가해 addrFirstName, addrLastName, addrCity, addrState라 쓰면 맥락이 좀 더 분명해진다.

 

 

반응형

'BackEnd > CleanCode' 카테고리의 다른 글

[CleanCode]6장 객체와 자료구조  (1) 2022.08.19
[CleanCode]4, 5장 주석 / 형식 맞추기  (0) 2022.08.15
[CleanCode]3장 함수  (0) 2022.08.02